2013년 5월 15일 수요일

Adobe Reader/ Acrobat 보안 업데이트 권고

□ 개요
   o Adobe社는 Adobe Reader와 Acrobat에 영향을 주는 취약점을 해결한 보안 업데이트를 발표[1]
   o 낮은 버전의 Adobe Reader/Acrobat 사용자는 악성코드 감염에 취약할 수 있으므로 해결방안에 따라
      최신버전으로 업데이트 권고

□ 설명
  o Adobe社는 Adobe Reader/Acrobat의 취약점 27개에 대한 보안 업데이트를 발표[1]
   - 임의코드 실행으로 이어질 수 있는 메모리 손상 취약점 (CVE-2013-2718, CVE-2013-2719, CVE-2013-2720,
     CVE-2013-2721, CVE-2013-2722, CVE-2013-2723, CVE-2013-2725, CVE-2013-2726, CVE-2013-2731,
     CVE-2013-2732, CVE-2013-2734, CVE-2013-2735, CVE-2013-2736, CVE-2013-3337, CVE-2013-3338,
     CVE-2013-3339, CVE-2013-3340, CVE-2013-3341)
   - 임의코드 실행으로 이어질 수 있는 정수형 언더플로우 취약점(CVE-2013-2727, CVE-2013-2549)
   - 샌드박스 보호기능 우회로 이어질 수 있는 ‘use-after-free’ 취약점(CVE-2013-2550)
   - 정보 유출로 이어질 수 있는 자바 스크립트 API 취약점 (CVE-2013-2737)
   - 임의코드 실행으로 이어질 수 있는 스택오버플로우 취약점(CVE-2013-2724)
   - 임의코드 실행으로 이어질 수 있는 버퍼오버플로우 취약점(CVE-2013-2730, CVE-2013-2733)
   - 임의코드 실행으로 이어질 수 있는 정수형 오버플로우 취약점(CVE-2013-2727, CVE-2013-2729)
   - 운영체제에 의해 블랙리스트 처리된 도메인을 Reader에서 처리하는데 발생한 취약점(CVE-2013-3342)

□ 해당 시스템
   o 영향 받는 소프트웨어
프로그램 동작환경 영향받는 버전
Adobe Reader XI 윈도우즈 및 Mac 11.0.02 및 이전 버전
Adobe Reader X 윈도우즈 및 Mac 10.1.6 및 이전 버전
Adobe Reader 9 윈도우즈, Mac 및 리눅스 9.5.4 및 이전 버전
Adobe Acrobat XI 윈도우즈 및 Mac 11.0.02 및 이전 버전
Adobe Acrobat X 윈도우즈 및 Mac 10.1.6 및 이전 버전
Adobe Acrobat 9 윈도우즈 및 Mac 9.5.4 및 이전버전


□ 해결방안
 o Adobe Reader 사용자
   - Adobe Download Center(http://get.adobe.com/kr/reader/otherversions/)를 방문하여
     최신 버전을 설치하거나 [메뉴]→[도움말]→[업데이트확인]을 이용하여 업그레이드
 o Adobe Acrobat 사용자
   - 아래의 Adobe Download Center를 방문하여 최신 버전을 설치하거나 [메뉴]→[도움말]→[업데이트확인]을
      이용하여 업그레이드  
윈도우즈 환경의 Adobe Acrobat
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows
맥킨토시 환경의 Adobe Acrobat Pro
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh

□ 용어 정리
 o PDF(Portable Document Format) : Adobe社가 개발한 다양한 플랫폼을 지원하는 전자문서 파일 형식
 o Adobe Acrobat : PDF 문서 편집/제작을 지원하는 상용 프로그램
 o Adobe Reader : PDF 문서의 편집 기능은 없이 보기/인쇄만 할 수 있는 무료 프로그램
 o Use After Free 취약점 : 소프트웨어 구현 시 동적 혹은 정적으로 할당된 메모리를 해제했음에도 불구하고
   이를 계속 참조(사용)하여 발생하는 취약점

□ 기타 문의사항
   o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

[참고사이트]
[1] http://www.adobe.com/support/security/bulletins/apsb13-15.html

원문: http://www.krcert.or.kr/kor/data/secNoticeView.jsp?p_bulletin_writing_sequence=2245